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1 Installing Weintek Built-in CODESYS

L_I WE!NTEK

Installing Weintek Built-in CODESYS allows users to easily create a cMT+CODESYS
project in CODESYS software. Please find the Package file we prepared and follow

these steps for quick installation.

1.

2.

3.

4.

First, get a copy of CODESYS Package file.

gt

weintek_2018012
4 package

On your PC, right-click the mouse button and select [Open with CODESYS

Package Manager].

Open with CODESYS Package Manager
Open with...

Share with 4

Restore previous versions

Send to »
Cut

Copy

Create shertcut
Delete

Rename

Properties

Select Complete Setup or Typical Setup (you may select any of these setup

types since the components used by Weintek Built-in CODESYS exist in both

types.)

£ Installation - Choose Setup Type

Weintek Built-in CODESYS [2018.1.24]
Please selectthe typeof setup youwould liketo perform.

@ Complete setup
All package components will be installed.

) Typical setup
The most commonly used package components will be installed.

Cancel MNext =

sl

[y

Click [Next] when seeing the following message.
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&7 Installation - Setup Completed

Weintek Built-in CODESYS [2018.1.24]

the summary.

The package has been successfully installed. Click Finish to exit the wizard or Next to see

(=l

[d

[ Mext> | [ Fnish |

5.  Theinstalled component will be shown in the installation summary.

&7 Installation - Summary

Weintek Built-in CODESYS [2018.1.24]

Installation summary

Summary:

(=l

[d

= Device description (1)

4 m

Component/DeviceDescription/Weintek-Cortex-embedded.devdesc.xml: Iter
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2 Connecting cMT CODESYS

2.1 Connecting Through Network
1. Connect cMT model’s LAN 1 port with a router or PC.
2. Tap Start button to open HMI system settings window.

3.  Open CODESYS page and find the IP address. By default, DHCP is used and
it will automatically obtain an IP address.

Setting CODESYS

System setting Activation status Activated (QA0000021)

@ Information
CODESYS status start

Application status start

2 General Login status logout

Ethernet(LAN1)
@ Network 1P address 192.168.2.105

ime/Date 255.255.252.0
O Ti ); Subnet mask 255.25
Gateway 92.168.1.254

£ HMI Name Mac address 00:0:26:0f:e3:3b

Version 20180516

2.2 Creating CODESYS Project
1.  Launch CODESYS V3.5 and click [File] » [New Project], and then select
[Standard project]. Enter the project name in Name filed, browse for the
location, and then click [OK] to leave.
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'}1% Mew Project @
Categories: Templates:
- Libraries B Bl
2 Projects L 'E 'E
Empty project  HMI project Standard Standard
project project w...
Standard
project w...
A project containing one device, one application, and an empty implementation for PLC_FPRG
Name: cMT3050c
Location:  C:\Usersiuser\Documents - E]
[ oK J [ Cancel l

2. Select Weintek Built-in CODESYS. CODESYS software provides 6 languages
that can be selected in [PLC_PRG in:] drop-down list as shown below.
Structure Text (ST) is used as an example in this manual.

Standard Project @

objects within this project:

- One programmable device as specified below

- A pragram PLC_PRG in thelanguage specified below

- A gyclic task which calls PLC_PRG

- A reference to the newest version of the Standard library currently installed.

You are about to create a new standard project. This wizard will create the following

Device: ’Weintek Built-in CODESYS (Weintek Labs., Inc.)

PLC_PRG in: [Structured Text (ST)

Continuous Function Chart (CFC)

Continuous Function Chart (CFC) - page-oriented
Function Block Diagram (FED)

Ladder Logic Diagram (LD)

Sequential Function Chart (SFC
Structured Text (ST,

3.

Double-click on Device (Weintek Built-in CODESYS) to open the settings

window.
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Devices >3 x
=[5 emTa0e0c [=]
= [ [pevice (wWentek Bultn CODESYS) |
=2 PLC Logic

=€} Application

m Library Manager
PLC_PRG {PRG)
= @ Task Configuration

L_| WE!NTEK

= @ MainTask
H PLC_PRE
gi Device X
Communication Settings Scan Network... | Gateway = Device ~
Applications
.
Backup and Restore
Files . % .
Gateway
Log
ateway-1| - VB -
[FLE SRS IP-Address:
localhost
PLC shell
Port
1217

Users and Groups

Task Deployment

Status

Information

4. Open Scan Network tab, CODESYS software will start searching for the

CODESYS devices on the same network. Select the desired device and then

click [OK] to leave. The last two IP address parts (between dots) are

converted into HEX digits and shown in this window. For example, if the IP
address of the CODESYS device is 192.168.2.118, please select HMI

Name[0276].

Select Device

Select the network path to the controller:

(sl

= '?"a‘o Gateway-1(scanning...)
cMT-00 [026A]
cMT-8B28-ted [0209]
cMT-DDBA [0241]
cMT-DD87 [023A]
cMT-E6CE [0243]
cMT-E6C8 [025E]

EEEEERR

Device Name:
Gateway-1

Driver:
TCF/IP

IP-Address:
localhost

Port:
1217

Cancel

5. The project will connect the selected device.
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Gateway
Gateway-1 - [0278] (active) -
IP-Address: Device Name:
localhost cMT-E33B
Port Device Address:
1217 0276
Target ID:
16BF 0001
Target Type:
4096
TargetVendor:

Weintek Labs., Inc.

TargetVersion:
3.5.10.30

@ Note

B |P address of the device can be entered in the field shown below.

Gateway
Gateway-1 - 192.168.2.113 -
IP-Address: Press ENTER to set active path...
localhost
Porz
1217
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3 Creating EasyBuilder Project

*Please use EasyBuilder Pro v6.00.02 build 20180410 or later versions.
3.1 Creating Tags

1. Create several tags in PLC_PRG tab and make tag “test” accumulate

automatically.

@ Device PLC_PRG X

1 PROGRAM FLC FRG

- z WAR
Ed read:BOOL;
4 write:BOOL;
5 test:INT;

& END VAR

1 testi=test+l;

3.2 Exporting Tag

1. Right-click on Application in Devices tree and then select [Add Object] »
[Symbol Configuration], use defaults.
Add Symbol Configuration IE'
"8 Createaremoteaccess symbol configuration.
Name:
Symbol Configuration
[ Include Comments in XML
[[] support OPC UA Features
Client side data layout
(©) Compatibility Layout
@ Optimized Layout
[ Add ] [ Cancel ]
2. Find PLC_PRG, select the variables to be exported, and then click [Build].
Symbaols Access Rights  Maximal  Attribute Type  Members  Comment
Ro |:| Constants
+ |:| IoConfig_Globals
- PLC_PRG
# read 4y "y BOOL
P test ) ™) INT
& write 4 " BOOL
3.

Select [Build] » [General code], the *.xml file can be found in the directory
of the project.
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3.3 Configuring EasyBuilder
1. Create a project and select Weintek Built-in CODESYS in the device list.

|  ExtendedMemory |  CelblauwDatNetwork |  Time@ymedDST | eMail | Recipes
Device | Model | Generl | Systemfetting | Remote | ecuity
Dienvice list W hat's mnr TP
Mo. Mame Location Address type Inti
= [LocalHMI | Local HMI Local cMT3090 (768 x 1024) -
W Local PLC4  |Weintek Built-in CODESYS Weintek Built-in CODESYS |- |

@

2. Open Tag Manager and click , and then click [Import Tag] to import

the *.xml file built in preceding steps.

Wariable List
Mame I‘I’agTabIe Find : [q ]

o X » 2 @AM DA O

Verifying Tags with device...

Symbols | Data Description

Import Tags...

Tag

3. The CODESYS tags can now be found in Tag Manager.
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My Application Variable List

- Application Name : ITagTable Find : [Q
[=)-Tags

iTagTabIe
O X » ¢ =

Symbols Data Type | Scan Rate () | Binary Access

B Tag
Application.PLC_PRG.rcad BOOL Dcfault (FALSE
- B Application.PLC_PRG.test |INT Default FALSE
Application.PLC_PRG.write BOOL Default }FALSE

Import Status

Imported tag information successfully.
0 warning(s)

4. Create a Numeric object and use “Application.PLC_PRG.test” for address.
After downloading the project to HMI, “test” tag data can be found.
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Connecting cMT CODESYS to iR-COP

I__| WE!NTEK

1. Right-click on Device (Weintek Built-in CODESYS) and then select [Add

Device].

2. Select [CANbus] » [CANbus], and then select [Add Device].

[l Add Device

Name: CANbus
Action:

@ Append device

(7) Update device

-]

+ s EtherCAT
+ - EB Ethernet Adapter

Enter a string for a fulltext search in all devices...  Vendor: | <Al vendors>
Mame Vender Version Description
= m Figldbuszes
= AN CANbus
ﬁ 35 - Smart Software Solutions GmbH 3.5.10.0
m MetX Canbus 35 - Smart Software Solutions GmbH 3.5.10.0

4| 1

Needed for all fieldbusse

CANbus on a netX device

-

3. CANbus (CANbus) can be found in Devices tree.

Devices ~ 0 X
=[5 eMTI090c (=]
= ﬂj Device (Weintek Built4n CODESYS)
=B pLC Logic
=1} Application

m Library Manager
PLC_PRG (PRG)
= @ Task Configuration
=gk MainTask

[ canbus {CANbus)

& pic PRG

4. Double-click on CANbus (CANbus) with the current window opened in
Devices tree, or right-click on CANbus (CANbus) and then select [Add

Device].

5. Click [Fieldbusses] » [CANopen] » [CANopen Manager] » [CANopen
Manager], and then select [Add Device].

(1] Add Device [
Name: CAMopen_Manager
Action:
@ Append device () Insert device () Update device
Enter a string for a fullkext search in all devices...  Vendor: | <all vendors: -
Mame Vendor Version Dy =
= m Fieldbusses
= Cifl CANopen £
= &ifl CANopenManager
m |CANopen_Manager 35 - Smart Software Solutions GmbH 3.5.10.0 ca
m CAMopen_Manager_FDT 35 - Smart Software Solutions GmbH 3.5.7.20 c
ﬁi CAMopen_Manager_SIL2 35 - Smart Software Solutions GrbH 3.5.10.0 ce_
e | - - . .
1 1 | 3

10
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6. Double-click on CANopen_Manager with the current window opened in

Devices tree or right-click on CANopen_Manager and then click [Add

Device].

7.  Click [Fieldbusses] » [CANopen] » [Remote Device], find iR-COP and then

select [Add Device].

[ Add Device (===
Name: iR_COP

Action:

@ Append device () Insert device () Update device

Enter a string for a fulltext search in all devices... ~ Vendor: | weintek Labs., Inc. -
Mame Vendor Version Descriptic
= ﬂj Fieldbusses

= Gifl CANopen
=€l Remote Device
m iR-COP Weintek Labs., Inc. Revision=16#00000001, FileVersion=1.1 Imported f

1 m b

8. Double click on CANbus (CANbus) in Devices tree to open the settings

window. Please select the correct baud rate for iR-COP in General tab.

& cMT3080c.project” - CODESYS

File Edit Wew Project Build ©Online Debug Tools Window Help
e d& # % OB | of X
Devices r 1 x (1) cambus x| [ iR_cop
=5 eMTI00C
= m Device {(Weintek Built-n CODESYS) General
i General
= El] PLC Logic
=} Application CANbus 1/0 Mapping Network:
m Library Manager
Status Baudrate (bitfs):

PLC_PRG (PRG)
= @ Task Configuration
= §8 MainTask

& PLC_PRG
=| @ canbus (CANbus)

= ﬂ CANopen_Manager (CAMopen_Manager]
(@ ®_cor (rcor)

Information

4 N 2

: f
52 Devices | B® Modules

9. Create CANopen variables in PLC_PRG, for example:

FROGRAM FLC_FRG

z VAR

3 x0 BOOL;
4 xl BOOL;
& END VAR

1

[E= N (=3

0 -

250000 -

10. Double click on iR_Cop in Devices tree to open the settings window. Select

related variables in CANopen I/0 Mapping tab.

11
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General Find Filter Show all - |
s Variable Mapping  Channel Address Type Unit  Description Il
=" DO byte 1 %GB0 USINT L
SDOs "% Application.PLC_PRG.x0 ] BitD S%E%e-5  BOOL [
"§ Application.PLC_PRG.x1 " Bit1 KOt BOOL MW
CANopen If0 Mapping K@ Bit2 %QX0.2 BOOL
] Bit3 %L0X0.3 BOOL
Status ] Bit4 QX0 4 BOOL
"% Bit5 %QX0.5  BOOL
Information L™ Bits %4QX0.6 BOOL
"% Bit7 %QX0.7  BOOL
+- "y DO byte 2 %QB1 USINT
- l +- T DO byte 3 %0B2 USINT i
.

11. When finished, click [Online] » [Login] to download the project to
CODESYS.

12
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5 Connecting cMT CODESYS to iR-ETN
1. Right-click on Device (Weintek Built-in CODESYS) and then select [Add

Device].
2. Select [Ethernet Adapter] » [Ethernet] and then click [Add Device].

[J Add Device (=23

Name: Ethernet

Action:
@ Append device (0) Update device

Enter a string for & fulltext search in all devices.,.  Vendor: | <all vendorss> -

Mame Vendor Version Description

= ﬂ'i Fieldbusses
+- AN CANbus
+ s EtherCAT
= - BB Ethernet Adapter
m Ethernet 35 - Smart Software Solutions GmbH 3.5.10.0 Ethernet Link.
+ - = EtherNet/TP il

m

3. Ethernet (Ethernet) can be found in Devices tree.

Devices - o X
=5 oMTI0%0 RETN (=]
= ﬁ |Device {Weintek Built-n CODESYS)
=2l PLC Logic

=} Application
m Library Manager
PLC_PRG (PRG)
= @ Task Configuration
= @ MainTask
&1 pLC_PRG
] Ethernet (Ethernet)

4. Double-click on Ethernet with the current window opened in Devices tree
or right-click on Ethernet and then select [Add Device].

5. Click [Fieldbusses] » [Modbus] » [Modbus TCP Master] » [Modbus TCP
Master], and then select [Add Device].

[ Add Device [==3a]

Name: Maodbus_TCP_Master

Action:

@ Append device () Insert device (7) Update device

Enter a string for a fulltext searchin all devices... = Vendor: | <all vendors> -

Mame WVender Wersion Description

= ﬂj Fieldbusses
+ - = EtherMet/IP
= Wil Modbus
= Wil Modbus TCP Master

m Modbus TCP Master 35 - Smart Software Solutions GmbH 3.5.10.0 A device thal—

+ - Wil ModbusTCP Slave Device -

m

6. Double-click on Modbus TCP Master with the current window opened in
Devices tree or right-click on Modbus TCP Master and then click [Add

13
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Device].
7.  Click [Fieldbusses] » [Modbus] » [Modbus TCP Slave] » [Modbus TCP Slave],
and then select [Add Device].

ﬁ

Name: Modbus_TCP_Slave

Action:

@ Append device (7) Insert device Flug device () Update device

Enter a string for & fulltext search in all devices.,,  Vendor: | <all vendors> -
Name Vendor Version Description
-ﬁ Fieldbusses

= iil§ Modbus
=¥ Modbus TCP Slave
i | 35 - Smart Software Solutions GmbH ~ 3.5.10.0 A generic Modbus ¢

8. Double click on Ethernet in the Devices tree, enter CODESYS’s IP address in
General tab, and then select [Change Operating System Settings].

(@ Device /Vm Ethernet x]/m Modbus_TCP_Master ] -
=5 oMTI090_R-ETN
=- m Device (Weintek Builtin CODESYS) General
—@l] PLC Logic Interface: ethd E]
—O Application Status

i r (71 Use Operating System Settings
m Library Manager -
PLC_PRG (PRG) Ethernet Device I/0 Mapping @ Change Operating System Settings

‘@ Task Configuration ; )
=¥ MainTask Information IP Address 192 . 1688 . 2 . 1%
45 pLC_PRG L subnet Mask 255 . 255 . 252 . O

-E---ﬂj|Eﬂ1emet(Eﬁ'1emet) ——
= m Modbus_TCP_Master (Modbus TCP Mastg

----- m Modbus_TCP_Slave (Modbus TCP Slg

— Default Gateway 192 . 188 . 1 . 254

I | 3

<
22 Devices | Modules
9.  When CODESYS is already connected, go to General tab and click the [...]

button near Interface field and select ethO.

ﬁ

Interfaces:

Name Diescription IP Address

Io 127.001
wvietl 10.2552552
IP Address 192 168 . 2 . 73
Subnet Mask 255 355 .352 .0

Diefanlt Gateway 192 188 . 1 . 254
MAC Lddress 00.0C:26:.0FE3 3B

[ ok [ Comeel |

10. Select Modbus_TCP_Slave in the Devices tree and then go to General tab
to set up IR-ETN’s IP address and Unit ID.

14
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Devices > 1 x [ Modbus_TCP_Slave x -
=-F) oMT3090_R-ETV
= m Device (Weintek Builtsn CODESYS) General Modbus-TCP
=B PLC Logic
=1} Application Modbus Slave Channel Slave IP Address: 192 . 188 . 2 . 144
:lf;iLYRZB(I;:QGT Madbus Slave Init Unit-I0 [1.247] !
= @ Task Configuration Response Timeout (ms) 1000
=8 MainTask ModbusTCPSlave Parameters Port w02
@ PLC_PRG ModbusTCPSlave If0 Mapping
= m Ethernet (Ethernet)
= m Modbus_TCP_Master (Modbus TCP Maste Status
m |Modbus_TCP_SIave (Modbus TCP Sla
q| = . Information

- - 4 [T G
22 Devices | F Modules

11. Open [Modbus Slave Channel] tab and create Modbus Variable.

ModbusChannel @

Channel

Name Read 0x-0

Access Type ’Read Discrete Inputs (Function Code 2) -
Trigger [Cydic V] Cycle Time (ms) 100
Comment

READ Register

Offset 0x0000 -
Length 1

Error Handling Keep last Value A

WRITE Register
Offset 0x0000

Length 0

oK ][ Cancel ]

ModbusChannel @

Channel

Name Write Ox-0

Access Type ’Wrihe Multiple Coils (Function Code 15) -
Trigger [Cydic V] Cycle Time (ms) 100
Comment

READ Register

Offset

Length 1

Error Handling Keep last Value

WRITE Register
Offset 0 -

Length 1

[ oK ][ Cancel ]

12. Open PLC_PRG in Devices tree, create tag and set Bool as data type. Write

15
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a command as shown below.

1 FROGRAM FLC _FRG
VAR
read:BOOL;
write:BOOL;
END VAR

[ T ~ N L T %]

(=} ]

1 write:=1l;

;3]

13. Open Modbus_TCP_Slave in Devices tree and then go to
[Modbus_TCPSlave 1/0 Mapping] tab to set up iR-ETN’s IP address and Unit

ID.
Variable Mapping  Channel Address Type Unit  Description
= Read 0x-0 %%IBO ARRAY [0..0] OF BYTE Read Discrete Inputs
= Read 0x-0[0] %eIB0 BYTE Read Discrete Inputs
“p Application. PLC_PRG.read "% Bit0 BeheaS BOOL 0x0000
=T Write Ox-0 %0B0 ARRAY [0..0] OF BYTE Write Multiple Coils
=" Write 0x-0[0] %QB0 BYTE Write Multiple Coils
"% Application.PLC_PRG.write " Bitd SLGWE8:8  BOOL 00000

14. When finished, click [Online] » [Login] to download the project to
CODESYS.

16
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6 Removing Weintek Built-in CODESYS

1. Click [Tools] » [Packages Manager].

I__| WE!NTEK

2. Find Weintek Built-in CODESYS and then click [Uninstall].

(7 Package Manager

Currently installed packages:

EX5

8| |

Install... ]

Sort by: |Name
Name Version Installation date Update info
@ CODESYS SoftMotion 4,1.1.0 201711/27 Free version 4.3.1.0 available!
L | Weintek Builtin CODESYS | 2018.1.24 201822

3. Click [Next] when seeing the window below.

Uninstall...

Updates

Search updates

License info

Mo license reg
License info no

&9 Uninstallation

Weintek Built-in CODESYS [2018.1.24]
Uninstallation

The package will be removed fromyour system. Click Next to continue.

Cancel

4. Removing the program.

17
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-

f# Uninstallation ez
Weintek Built-in CODESYS [2018.1.24]
Pleasewaitwhile the packageisbeing uninstalled. m
WEINTEX
Initializing...
5. Click [Finish].
¥ Uninstallation (=25
Weintek Built-in CODESYS [2018.1.24] m
WEINTEX

The package has been successfully removed from your system. Click Finish to exit the
wizard.

18
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7 Frequently Asked Questions
7.1 Questions Related to IP Address

Q1. How to use static IP address for cMT CODESYS?

A: Please follow these steps.

L_| WE!NTEK

1. Right-click on “Device (Weintek Built-in CODESYS)” and select [Add Device].
2. Select [Ethernet Adapter] » [Ethernet] and then select [Add Device].

[ Add Device

Name: Ethernet
Action:
@ Append device (0) Update device

(sl

Enter a string for & fulltext search in all devices.,.  Vendor: | <all vendorss>

Mame Vendor
= ﬂ'i Fieldbusses

+- AN CANbus

+ s EtherCAT

= - BB Ethernet Adapter

+ - = EtherNet/TP

m Ethernet 35 - Smart Software Solutions GmbH

Version

3.5.10,0

3. In Device tree find Ethernet and double click it.

Devices

* o x

=2 aMTI0N0_R-ETV

=]

= ﬁ |Device {Weintek Built-n CODESYS)

=Y PLC Logic
=} Application
m Library Manager
PLC_PRG (PRG)
= @ Task Configuration
= @ MainTask
&1 pLC_PRG
] Ethernet (Ethernet)

4. The following window opens, click [...] button.

General
Interface:
Status
@ Use Operating System Settings
Ethernet Device If0 Mapping Change Operating System Settings
Information IP Address 192 . 168 . 0 .
Subnet Mask 255 . 255 . 255 .
Default Gateway a .0 .0

Description

Ethernet Link.

1

]

]

5. Select “ethQ”. Please see “2.2 Creating CODESYS Project” to finish CODESYS

project settings before doing this step.

19
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MNetwork Adapters @
Interfaces:
Hame Description IP Address
lo 127001
1'_3.'.'-:'.15:5:_11'.11'_'4
wietl 102552552
IF Address 192 168 . 2 . 119
Subnet Mask 255 255 252 . 0
Diefanlt Gateway 192 168 . 1 254
MAC hddiress 00:0C:26:0FE3:3B

[ oK ][ Comeel

6. Select [Change Operating System Settings].

General
| Interface: ethd B

Status
(7) Use Operating System Settings

Ethernet Device If0 Mapping @ Change Operating System Settings |

Information IP Address 192 . 188 . 2 . 144
Subnet Mask 255 . 255 . 252 . 0
Default Gateway 192 . 168 . 1 . 254

7. Download the project to cMT CODESYS.

Q2. Why my CODESYS Gateway shows 0.0.0.0?
A: When using static IP for cMT CODESYS, its IP address will be displayed as
0.0.0.0.

Q3. Can | use the same domain for cMT HMI’s LAN 1 and LAN 2?
A: This is acceptable only when cMT HMI has CODESYS activated.

7.2 Questions Related to CODESYS

Q1. When the indicator of CODESYS Gateway lights up in red, how can |
connect to the device?

A: When CODESYS Gateway is not properly started or installed, its indicator will

light up in red. Please try the following 3 methods to solve this situation.

1. Click the icon of “CODESYS Gateway SysTray” in system settings and then
click [Start Gateway].

2. Add new gateway and enter HMI IP.

20
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Scan Metwork... || Gateway «| Device -

| Add new gateway...

Manage gateways. ..

Configure the local Gateway...

Gateway @
Name: Gateway-2
Driver: "rcpﬂp v]
IP-Address 192.168.2.144
Fort 1217

3. Re-install CODESYS Gateway.

CODESYS V3.5 5P12 Patch 1 - InstallShield Wizard

Select Features
Select the features setup will install.

Select the features you want to install, and deselect the features you do not want to install.

~[]CODESYS V3 peseTpsen
CODESYS Converter E0E 34 ERE T oo
CODESYS Gateway ?;Ijr::niﬁcna?jztner;a;r) for
CODESYS OPC Server 3 CODESYS V3 '

CODESYS Gateway V2.3
[V]CODESYS Control Win W3

0.00 MB of space required on the C drive
11217.01 MB available on the C drive

[ < Back ][ Mext = l[ Cancel ]

Q2. Why a triangle icon shows near Modbus_TCP_Slave device when | log in
HMI in CODESYS software?

& ﬂj Modbus_TCP_Slave (Modbus TCFP Slave)

A: This means that HMI cannot connect Modbus TCP/IP device via CODESYS.
Please check the IP settings and make sure the cable is properly connected.

7.3 Questions Related to Downloading cMT CODESYS File
Q1. How to update CODESYS firmware?
A:
There are 2 ways to update CODESYS firmware.

1. Launch Utility Manager and select cMT Series » Maintenance » CODESYS
Firmware Update. Browse for the firmware file and click [Update].
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' CODESYS Firmware Update

4] P, HMIName |

HMI: cMT-E33B v

Search All

Firmware :  C:\codesys_20180704.229.bin

*Updating firmware will also restart HMI.

Password : 111111 [T mask

Update

2. Enter cMT HMI’s IP address in the website browser and find [CODESYS] »

[CODESYS update] tab. Select the file and click [Update].

identity:
1 System Setting

CODESYS
Network LB
Date/Time Status  Projectupdate  CODESYS update

HMI Name Please select file to upload
History
- IEIFEE | Application.app (fapp)

i BT SIS | Application.cre (*erc)

System Password
Enhanced Security
EasyAccess 2.0

lii CODESYS

Update

Q2. How to download CODESYS project using website?

1. In CODESYS software select [Online] » [Create boot application]. An *.app

file and a *.crc file will be generated.
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® Manual.project - CODESYS

File Edit View Project Builld | Online | Debug Toolz Window Help
PEE & 5 Logn Alt+FE
Logout Ctrl+Fa
Devices | Create boot application
= -@ Manua/ Download
= pevice (weintek Builtin CQ Online Change
= 8 PLC Logic Source download to connected device
= u Application

ﬁ Ethernet (Ethernet)

m Library Manag:
PLC_PRG (PRG
-1 Symbol Config

= @ Task Configurz
=58 MairTask

8] pLC_p

Multiple Download. ..
Reset warm

Reset cold

Reset origin
Simulation

Security

Operating Mode

Enter cMT HMI’s IP address in the website browser and find [CODESYS] »
[Project update] tab. Select the files generated in the last step and click

[Update].

Network

Date/Time

HMI Name

History

Email

Project Management

System Password

Enhanced Security

EasyAccess 2.0

lii CODESYS

_ODESYS

Status  Project update

Please select file to upload

EIFEE | Application.app
EIFRE | Application.cre

Update

CODESYS update
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